Brand New *BROKEN* Silhouette

Post any questions here on Silhouette Cameo & SD Cutters.

Brand New *BROKEN* Silhouette

PostPosted by nyoung27 » Wed Aug 13, 2014 10:17 pm

So my silhouette cameo came in the mail today and won't work! When I turn it on it makes a really loud noise that lasts for about 20 seconds and then stops. The left side of the bar won't lift up when I move the lever on the right hand side and the whole black part (motor??) won't move. The blade moves up and down, but the whole thing will not move left and right. I'm seriously dying. School starts tomorrow and all I have is a brand new broken machine. Please help. Please tell me there is a simple fix so I can live again. I know I'm dramatic. :)
nyoung27
 
Posts: 1
Joined: Wed Aug 13, 2014 10:12 pm

Re: Brand New *BROKEN* Silhouette

PostPosted by Dixie's Chick » Thu Aug 14, 2014 8:37 am

I'm sorry your cameo isn't working. Did you call whoever you bought it from and tell them it's not working? It may be some tape or plastic piece you have not taken off. Either way, make a call get yourself sorted out and up a and running.

Happy first day of school :-)
-Linda
Sparkle-Gear
User avatar
Dixie's Chick
 
Posts: 5729
Joined: Sun Sep 25, 2011 7:00 am
Location: North of Boston

Re: Brand New *BROKEN* Silhouette

PostPosted by Administrator » Thu Aug 14, 2014 8:49 am

That does not sound good. You can give the office a call and see if we can help you out. Did you purchase the Cameo on our website. If so just let them know the order number and they can look into it. If another website you would need to call them for the warranty part. However, we will still try to help. Sorry for the issues. :( Matt
User avatar
Administrator
Site Admin
 
Posts: 1443
Joined: Sat Sep 24, 2011 2:30 pm
Location: Sarasota, FL


Return to Silhouette Cameo & SD Cutter Questions

Who is online

Users browsing this forum: No registered users and 0 guests

cron